Feature Tutorials

Multi-Phase Single-Crystal Diffraction Patterns

SingleCrystal allows you to display one diffraction pattern per window. How then does one go about simulating diffraction from an intergrowth of two or more phases? In the following tutorial we'll set up two diffraction patterns with a precise orientation relationship. We'll then merge the two patterns - taking advantage of singleCrystal's PDF graphics export.

composite diffraction pattern

A simulated diffraction pattern for a two-phase intergrowth, created using SingleCrystal's PDF export capability.

Introduction

Let us suppose that you wish to create a composite diffraction pattern for two cubic structures, A and B.

(We will use the oxide minerals spinel and periclase as phases A and B, respectively; both are included in the CrystalMaker crystals library, under: Minerals/Non-Silicates/Oxides.)

The orientation relationship will be:

  1. The direction [111] in phase A is parallel to
    the direction [001] in phase B;
  2. The normal to plane (1 -1 0) in phase A is parallel to
    the normal to plane (1 0 0) in phase B.

Complete the following steps:

1   Open "phase A" and "phase B" in separate SingleCrystal diffraction windows.

2   Specify a view direction of [111] for phase A (View > View Direction) and [001] for phase B.

You now have two phases with their view directions are aligned; however, the complete orientation relationship has still to be defined: you need to ensure that the other directions are specified. We'll do this using the stereogram.

3   For Phase A, you need to add the pole 1 -1 0 to the stereogram. You do this by entering the indices 1 -1 0 in the hkl fields of the stereogram drawer, choosing a unique colour, then clicking the Add button.

You will probably find that the pole ends up at the top of the stereogram; we'll rotate the structure through 90 degrees clockwise, so that it ends up on the right-hand side of the stereogram:

  • Choose 90 from the Tilt Angle popup menu (bottom of the diffraction window).

  • Click the Rotate Z button to rotate your structure (If this button isn't visible in your Toolbar, choose the View > Customize Toolbar command, and drag the "+z" or "-z" icons to your toolbar.)

4   Switch to the "Phase B" window. Specify a view direction of [001], then view the stereogram to see where the (100) pole lies. If necessary, rotate your structure about the view direction (+z button).

5   Double-check that the scales are correct for each window; if they are different, use the Diffract > Scale command to set the scale.

6   You might now wish to change the colours of diffraction spots, so that the two patterns are more easily distinguished. Use the View > Colour Options command, and choose different colours for the two patterns' reflexions (e.g., red for Phase A, and blue for Phase B).

Your two diffraction windows should now resemble the two shown below:

phase A diffraction pattern

Oriented diffraction pattern for phase A

phase B diffraction pattern

Oriented diffraction pattern for phase B

7   For Phase A, choose the Edit > Copy Diffraction Pattern command to copy a PDF graphic to the clipboard. Paste this into a vector graphics program such as Adobe Illustrator (*). After pasting, you will need to ungroup the graphic, and delete the background rectangle. You should probably then select the rest of the diffraction pattern and group it again.

8   Repeat for Phase B. You now have a composite diffraction pattern!

(*) You can also use a paint program such as Adobe Photoshop, pasting the two diffraction patterns into separate layers. In this case, you will need to make the uppermost layer partially transparent - or alternatively, choose a transfer mode such as "Darken", to ensure that the lower pattern shows through.

Copyright © 2016 CrystalMaker Software Ltd. All rights reserved.